~~~ Our Members' Open Range Coaches ~~~
Click HERE for the Home Page Scrolling Photos
Open Range RV Owners Forum




~ Upcoming Open Range RV Owners Forum Rallies ~

->> 2018 Texas Rally - May 6-11 - Kerrville, TX ~~ 2018 Coming Home Rally - June 4-10 - Goshen, IN ~~ 2018 Northeast Wine Campout - Sept 19-23 - Bath, NY
It is currently Sun Jan 21, 2018 9:29 pm

All times are UTC - 5 hours


Forum rules


Please click here to view the forum rules



Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Furnace Not working
PostPosted: Mon Sep 18, 2017 10:30 am 
Offline

Joined: Wed Mar 08, 2017 4:45 pm
Posts: 31
OR Year: 2017
OR Model: 374BHS
Member ID: ORF-12069
Hey Guys

I am up north in Canada and starting to drop to 0 degrees C in the evenings and this morning I woke up quite cold and noticed my furnace was not kicking on. I checked all the obvious things such as propane, breakers etc but can’t figure out why it sins turning on. I checked the fuse for the thermostat and it was good. The fan will turn on if I take it off of AUTO mode, but I can not get the furnace to kick on. I noticed that the furnace has a 15amp fuse as well but it is solid black and unable to see if it is good? should I try to put a different 15amp fuse in there and see if that works?

anyways just wanted to know if anyone has some troubleshooting tips, at this point I am not sure if the thermostat or furnace is buggered?

It will be some cold nights if i can’t get it sorted out.

Cheers

_________________
2018 - 374 BHS Open Range Roamer
2017 - Chevy Duramax 3500 Crew Cab Standard Box
Andersen Ultimate 5th Wheel Connection 2


Top
 Profile  
Reply with quote  
 Post subject: Re: Furnace Not working
PostPosted: Mon Sep 18, 2017 12:17 pm 
Offline
User avatar

Joined: Tue Oct 01, 2013 2:07 pm
Posts: 6613
Location: Nazareth, PA
OR Year: 2014
OR Model: 427BHS
Member ID: ORF-3771
Is it a standard automotive blade fuse? If so, it should not be solid black... that may be burnt from where it blew.

However, if it works on low or high, that would say the fuse is good. Is it the furnace fan that is kicking on or the one in the AC unit in the ceiling? Silly question but do you have the mode set to HEAT on the thermostat?

_________________
Mark
2014 Open Range 427BHS
2011 Ford F-350 Crew Cab 6.7L Powerstroke Diesel
Pullrite Superglide 18K
Firestone Ride Rite Airbags
Furrion Wireless Observation Camera
TST 510 TPMS
Maxxis M8008s


Top
 Profile  
Reply with quote  
 Post subject: Re: Furnace Not working
PostPosted: Mon Sep 18, 2017 5:22 pm 
Offline

Joined: Wed Mar 08, 2017 4:45 pm
Posts: 31
OR Year: 2017
OR Model: 374BHS
Member ID: ORF-12069
BCM wrote:
Is it a standard automotive blade fuse? If so, it should not be solid black... that may be burnt from where it blew.

However, if it works on low or high, that would say the fuse is good. Is it the furnace fan that is kicking on or the one in the AC unit in the ceiling? Silly question but do you have the mode set to HEAT on the thermostat?


The fuse for the furnace is not the same as the other (automobile 15 amp fuses) it is solid black with no window. The fan I can turn on if I manually turn it to high or low, but the furnace still does not kick in. I have the thermostat set to heat and it will not turn on whether i am on auto or the fan is set to low or high.

_________________
2018 - 374 BHS Open Range Roamer
2017 - Chevy Duramax 3500 Crew Cab Standard Box
Andersen Ultimate 5th Wheel Connection 2


Top
 Profile  
Reply with quote  
 Post subject: Re: Furnace Not working
PostPosted: Mon Sep 18, 2017 7:56 pm 
Offline

Joined: Sat Jul 29, 2017 5:44 pm
Posts: 55
OR Year: 2018
OR Model: 337RLS5TH
Member ID: ORF-13437
The wife and I had the same problem with our 2017 Jayco . It was a loose ground wire at the furnace . We pulled the panel of inside the camper and the wire was right there . (it was a white wire) The dealer hooked the wire up and it worked.

_________________
Don & Sandy & Doxies: Patches & Ruffie
2018 337rls Open Range Roamer 5th Wheel
2001 GMC 2500HD 8.1


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group