~~~ Our Members' Open Range Coaches ~~~
Click HERE for the Home Page Scrolling Photos
Open Range RV Owners Forum




~ Upcoming Open Range RV Owners Forum Rallies ~

->> 2018 Texas Rally - May 6-11 - Kerrville, TX ~~ 2018 Coming Home Rally - June 4-10 - Goshen, IN ~~ 2018 Northeast Wine Campout - Sept 19-23 - Bath, NY
It is currently Sun Jan 21, 2018 9:27 am

All times are UTC - 5 hours


Forum rules


Please click here to view the forum rules



Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Post subject: Atwood furnace issues
PostPosted: Sun Dec 03, 2017 9:52 am 
Offline
User avatar

Joined: Thu Aug 17, 2017 9:52 pm
Posts: 2
OR Year: 2015
OR Model: 274rls
Member ID: ORF-13608
I am running an Atwood furnace in my 2015 rls 274 I bought used this summer. It has been working great until recently when it now refuses to turn on. All the basics check out (fuses, propane pressure, thermostat, etc). Verified the breaker on the unit is working and the blower runs when I jump power to it. Red light is blinking indicating an air flow issue based on the diagnostics labeled on the blower body. That error seems to not be able to clear as the unit doesn't even energise the blower when turned on from the thermostat. Only thing I can think is that it smoked the circuit board. Would love to hear some advice before I tear the board out and test it. I appreciate any info you can shoot my way, thanks!


Top
 Profile  
Reply with quote  
PostPosted: Sun Dec 03, 2017 1:35 pm 
Offline
User avatar

Joined: Thu Jun 23, 2011 11:59 pm
Posts: 4761
Location: West Monroe LoUiSiAna hometown of Duck Dynasty
OR Year: 2009
OR Model: JF335BHS
Member ID: ORF-0013
I suggest removing all power from the furnace for a few minutes to see if it might reset--
and also make sure the exhaust is clear of any critters or debris--recently found dirt
dauber nest and spider webs had mine disabled.

_________________
Bill & Shirley
USAF 1958-1962


09 Open Range JF335BHS ser # 750
Furrion RV cam / TST-TPMS
02 F250 7.3 PSD CC SB XLT Lariat


Top
 Profile  
Reply with quote  
PostPosted: Sun Dec 03, 2017 3:28 pm 
Offline

Joined: Sat Mar 12, 2016 3:39 pm
Posts: 55
Location: Columbus, NE
OR Year: 2016
OR Model: RF376FBH
Member ID: ORF-9063
My furnace would not work earlier this year. The blower would start but the burner would not fire. I had to remove the panel on the exterior of the furnace and press a reset button. Everything worked fine after that.

_________________
Mike
2016 Roamer 376FBH
2016 F350 6.7L CC SB
18k Hijacker Autoslide


Top
 Profile  
Reply with quote  
PostPosted: Mon Dec 04, 2017 12:26 pm 
Offline
User avatar

Joined: Sat Nov 08, 2014 11:46 pm
Posts: 2131
Location: Central Coast of CA
OR Year: 2015
OR Model: 337RLS
Member ID: ORF-5907
If the above ideas do not work, pull it and check the blower itself. Either the control board or the blower motor itself have probably failed. NOTHING works on these if the blower does not function. That is a safety design.

Make sure you can turn the blower by hand first, and then you'll have to isolate it electrically (disconnect the wires) and apply proper voltage to it separately and test the blower. If it works, it's most likely the control board.

Before doing any of that you need to make sure the thermostat itself is actually working. A wiring diagram showing the power source to the tstat and the heat wire should be used.

_________________
2015 Open Range 337RLS
2006 GMC 2500 Duramax CCSB
Central Coast of CA
Reese Sidewinder Pin Box
B&W Patriot 5th wheel hitch
Bridgestone Duravis R250 tires


Top
 Profile  
Reply with quote  
PostPosted: Tue Dec 05, 2017 9:30 am 
Offline

Joined: Tue Oct 20, 2015 1:03 pm
Posts: 395
OR Year: 2012
OR Model: 391RES
Member ID: ORF-8159
I am not sure if I have an Attwood furnace or not. There is a power on rocker switch on top of mine and I had my big hand up there at one time and turned off the switch without knowing it. The T stat A/C and furnace would not work. With this switch turned off for 30 seconds and turned back on you can reset the system. If the blower then starts up, but the main flame doesn't come on you will need to look for what they call a sail switch. If the sail switch doesn't close after the fan starts up the main burner will not come on. The sail switch proves that the blower is running. After a number of try's by the furnace and no blower indication the mother board will lockout and start the red light flashing. By turning off the rocker switch and back on you reset the system. Jerry

_________________
2012 OR 391RES
2006 GMC 2500
Edge tuner
6.6 Duramax LBZ w/Allison 6 speed

Every exit is an entrance to a new experience


Top
 Profile  
Reply with quote  
PostPosted: Tue Dec 05, 2017 10:12 am 
Offline
User avatar

Joined: Sat Nov 08, 2014 11:46 pm
Posts: 2131
Location: Central Coast of CA
OR Year: 2015
OR Model: 337RLS
Member ID: ORF-5907
I believe turning off the breaker at the panel will do the same thing.

_________________
2015 Open Range 337RLS
2006 GMC 2500 Duramax CCSB
Central Coast of CA
Reese Sidewinder Pin Box
B&W Patriot 5th wheel hitch
Bridgestone Duravis R250 tires


Top
 Profile  
Reply with quote  
PostPosted: Tue Dec 05, 2017 4:13 pm 
Offline
User avatar

Joined: Thu Aug 17, 2017 9:52 pm
Posts: 2
OR Year: 2015
OR Model: 274rls
Member ID: ORF-13608
Well all fixed. It was the board after all. Swapped out and purring away now.
Pretty impressive that a rig of this supposed "quality" burned up the stock circuit board in less than 2 years.
I appreciate the replies, happy trails!


Top
 Profile  
Reply with quote  
PostPosted: Tue Dec 05, 2017 5:20 pm 
Offline
User avatar

Joined: Sat Nov 08, 2014 11:46 pm
Posts: 2131
Location: Central Coast of CA
OR Year: 2015
OR Model: 337RLS
Member ID: ORF-5907
OR has no control over the furnace makers QC. Every thing made can and will fail, some sooner than others.

_________________
2015 Open Range 337RLS
2006 GMC 2500 Duramax CCSB
Central Coast of CA
Reese Sidewinder Pin Box
B&W Patriot 5th wheel hitch
Bridgestone Duravis R250 tires


Top
 Profile  
Reply with quote  
PostPosted: Tue Dec 05, 2017 5:58 pm 
Offline
User avatar

Joined: Tue Oct 01, 2013 2:07 pm
Posts: 6610
Location: Nazareth, PA
OR Year: 2014
OR Model: 427BHS
Member ID: ORF-3771
Being out of warranty I have started to amass replacement parts so I'm not stuck on the road. Replacement boards for the furnace and water heater, sail switches, thermocouple for the water heater. Anything that can fail I hopefully have on board.

_________________
Mark
2014 Open Range 427BHS
2011 Ford F-350 Crew Cab 6.7L Powerstroke Diesel
Pullrite Superglide 18K
Firestone Ride Rite Airbags
Furrion Wireless Observation Camera
TST 510 TPMS
Maxxis M8008s


Top
 Profile  
Reply with quote  
PostPosted: Tue Dec 05, 2017 7:26 pm 
Offline
User avatar

Joined: Wed Aug 19, 2015 8:42 am
Posts: 3572
Location: Mesa, AZ
OR Year: 2016
OR Model: 319RLS
Member ID: ORF-7680
As I backup I pull another trailer behind mine.


You do not have the required permissions to view the files attached to this post.

_________________
Earl & Elaine, Mesa Arizona, 16 LT319RLS 5'ver,
15 Ram 2500 4X4 C/cab 6.7 Diesel, Std Bed, B&W 16K Hitch,
2 Honda EU2000i, TST07SE TPMS, Titan Disc Brakes, Dish Sat, Visio 48" TV, M/R SRE4000 3 X-members, HD Shackles, Carlisle Tires.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group